Browser Requirements for WeWorked

We now prompt users using older, unsupported browsers that they need to upgrade. WeWorked is designed to be used with the latest technologies found in modern browsers. Modern browsers ensure you have the best experience. The application is faster, more responsive, and more secure. 

You must use one of the following browsers to use WeWorked:

Google Chrome (Recommended)
Internet Explorer 9+
Safari 5+

Try Chrome Frame for those that are required to use older versions of Internet Explorer.